YaBB - Yet another Bulletin Board   Welcome, Guest. Please Login or Register
 
  HomeHelpSearchLoginRegister  
 
 
problems to installl the iDataAgent on Linux (Read 4019 times)
20. Jul 2012 at 09:24

chrisMN   Offline
YaBB Newbies
Commvault Support

Posts: 2
*
 
Hello,
on our Linux server we can only install the base and base0 client but the iDataAgent doesn't install himself. Why?
In the logfile of the job i see this:
13332 24d8 07/20 09:06:09 187053 Computing Updates to be installed on the client
13332 24d8 07/20 09:06:09 187053 SP found in cache [6b]
13332 24d8 07/20 09:06:09 187053 CVRemoteClient::GetInstalledUpdatesListFromDB() - No updates installed on client [230]
13332 24d8 07/20 09:06:09 187053 Packages and Updates installed on client:
13332 24d8 07/20 09:06:09 187053 [SIMID] : [1002] Base Client
13332 24d8 07/20 09:06:09 187053      SP to be installed [6b]
13332 24d8 07/20 09:06:09 187053 [SIMID] : [1003] Base0 Module
13332 24d8 07/20 09:06:09 187053      SP to be installed [6b]
13332 24d8 07/20 09:06:10 187053 [SIMID] : [1101] UNIX File System iDataAgent
13332 24d8 07/20 09:06:10 187053      SP to be installed [6b]
13332 24d8 07/20 09:06:10 187053 Following Packages will be installed on client:
13332 24d8 07/20 09:06:10 187053 Package Name [ UNIX File System iDataAgent ] ID [ 1101 ]
13332 24d8 07/20 09:06:10 187053 Using Commserve cache for install/upgrade
... but i can't use it to make a filesystem-backup of this server.

If i try to install it locally i ever get this message:
"Received CommServe Software Install Manager Error 67109493
Failed in Install Requirement phase for [UNIX File Syszem iDataAgent] package.

Please help me to install the simpana agent for backup file system.

Is there a way to installl the iDataAgent seperatly ?


regards
chris

 
IP Logged
 
Reply #1 - 20. Jul 2012 at 16:03

aeikesh   Offline
YaBB Newbies
Commvault Support
India

Posts: 22
*
 
Hi Chris,

The log snippets that you have posted are not much to go by. However at first glance, it looks like the glibc version is not up to the mark. Can you check the version?
 
IP Logged
 
Reply #2 - 23. Jul 2012 at 09:02

chrisMN   Offline
YaBB Newbies
Commvault Support

Posts: 2
*
 
we use this glibc-Version on OperSuse

glibc  2.14.1-14.27.1

How can i insert a screenshot?


But if i installed the Software remote from the Commserve Console it goes and install the  Base  and the  Base0  components, but the iDataAgent for the FileSystem Backup wouldn't installed. At this point the installation breaks.
On the server the /opt/simpana was installed but i can not make a backup.
Cry Undecided
« Last Edit: 23. Jul 2012 at 14:06 by chrisMN »  
IP Logged
 
Reply #3 - 02. Aug 2012 at 00:57

theherd82   Offline
YaBB Newbies
Commvault Support

Posts: 2
*
 
Hi chrisMN,

I'd almost check if you have firewalls setup correctly and see if the commserve's cache is up-to-date. Might also be worth checking one of the logs on the commserve as well - as it may have some information that may give some details information (I think it's called like the CvInstallClient or something).
 
IP Logged
 
Reply #4 - 07. Aug 2012 at 06:03

bill_bob   Offline
YaBB Newbies
Commvault Support

Posts: 2
*
 
Hi Everyone,

I'm getting the same error 67109493 trying to install 9.0.0(BUILD84) on a Solaris x86 host.  I have successfully installed it on a CentOS host so I don't think I've got a firewall problem.  My install log says this:

<clientComposition activateClient="1" packageDeliveryOption="0">
<clientInfo>
<client cvdPort="8400" evmgrcPort="8402">
<clientEntity _type_="3" clientId="0" clientName=<redacted> hostName=<redacted> type="0"/>
</client>
</clientInfo>
<clientError ErrorCode="67109493" ErrorString="Failed in Install Requirement phase for [UNIX File System iDataAgent] package. Please check Commserve log files for more information." errorLevel="2"/>
</clientComposition>
<SimError ErrorCode="4294967295"/>
</CVInstallManager_ClientSetup>


Up until that point the log looks pretty much identical to the install log for the CentOS box that worked.

I'd love to hear from anyone who has solved this issue.

Regards,

Bill
 
IP Logged
 
Reply #5 - 10. Aug 2012 at 04:25

bill_bob   Offline
YaBB Newbies
Commvault Support

Posts: 2
*
 
bill_bob wrote on 07. Aug 2012 at 06:03:
Hi Everyone,

I'm getting the same error 67109493 trying to install 9.0.0(BUILD84) on a Solaris x86 host.  I have successfully installed it on a CentOS host so I don't think I've got a firewall problem.  My install log says this:

<clientComposition activateClient="1" packageDeliveryOption="0">
<clientInfo>
<client cvdPort="8400" evmgrcPort="8402">
<clientEntity _type_="3" clientId="0" clientName=<redacted> hostName=<redacted> type="0"/>
</client>
</clientInfo>
<clientError ErrorCode="67109493" ErrorString="Failed in Install Requirement phase for [UNIX File System iDataAgent] package. Please check Commserve log files for more information." errorLevel="2"/>
</clientComposition>
<SimError ErrorCode="4294967295"/>
</CVInstallManager_ClientSetup>


Up until that point the log looks pretty much identical to the install log for the CentOS box that worked.

I'd love to hear from anyone who has solved this issue.

Regards,

Bill



This issue has been resolved for me by making sure I log in to the machine as root.  If I "su" to root and try to install I get the error.  If I log in directly as root the installation works.  Probably something in my PATH being inherited when I su'ed to root.

I hope this helps someone else.

Cheers,

Bill
 
IP Logged
 
Reply #6 - 16. Aug 2012 at 03:02

-=PsY=-   Offline
Global Moderator
Commvault User

Posts: 405
*****
 
Thanks for the update.
 
IP Logged